BSE: Delayed Price Updates and Order Placement in Certain Option Strikes

Incident Report for Upstox

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 09:45 IST

Monitoring

Earlier today, some users experienced delays in price updates and order placement for certain option strikes on the BSE F&O segment. The issue has been reported to the exchange, and we are monitoring the situation closely.
Posted Jul 29, 2026 - 09:25 IST