Delay in Processing Delivery Orders
Incident Report for
Upstox
Resolved
This incident has been resolved.
Posted
Nov
18
,
2024
-
09:48
IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
18
,
2024
-
09:47
IST
Identified
The issue has been identified and a fix is being implemented.
Posted
Nov
18
,
2024
-
09:45
IST
Investigating
We are currently investigating this issue.
Posted
Nov
18
,
2024
-
09:40
IST
This incident affected: Order Placement.
×
Subscribe to Incident
Subscribe to updates for
Delay in Processing Delivery Orders
via . You'll receive .