Temporary Service Disruption
Incident Report for
Upstox
Resolved
This incident has been resolved.
Posted
Dec
05
,
2025
-
14:58
IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Dec
05
,
2025
-
14:45
IST
Investigating
We’re experiencing a global outage affecting a few of our services. Our team is working on it, and we’ll keep you updated here.
Posted
Dec
05
,
2025
-
14:37
IST
×
Subscribe to Incident
Subscribe to updates for
Temporary Service Disruption
via . You'll receive .